Index files not located in space folder

I am searching for a way to include markdown files in my space, that are not stored in the space’s folder. This is what I tried:

  • Creating a symlink within the SB space, pointing to the folder containing the markdown files → Files are not indexed
  • Federate the folder by federate: uri: file:///MyExternalMdFiles/ → fails since file URIs do not seem to be supported

Is there anything i’ve overlooked?

I’ve got an automation workflow that checks my email, and exports some mails as markdown file to OneDrive. These are synced to my local machine and I’d like to be able to use them in my SB space (that is not located on OneDrive).

Hmm. The symlink approach should work. Note it may take a bit for this to be detected. If it doesn’t work, even after a Space: Reindex please create a bug ticket. I’m pretty sure this worked before.

OneDrive does a thing where it creates files in the filesystem without the contents, and then downloads the contents when the file is accessed (at least on Windows). Maybe that has something to do with it?

If that’s the case that would explain it for sure

I examined this today. On a mac it doesn’t seem to recognise symlinked folders at all. Not even the ones completely unrelated to OneDrive. It works well for files. I’ll create a bug issue.